After-Hours Call Routing Issue
Incident Report for CIT Services Status
Resolved
This incident has been resolved.
Posted Jul 13, 2023 - 22:52 CDT
Investigating
We are currently investigating this issue.
Posted Jul 13, 2023 - 22:34 CDT
This incident affected: Managed Services (CIT Service Desk Phones).