Call Tower Phone Issues
Incident Report for CIT Services Status
Resolved
This incident has been resolved.
Posted Oct 07, 2024 - 12:08 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 07, 2024 - 11:36 CDT
Identified
Call Tower is looking into some issues causing problems with customers able to answer inbound calls and this is affecting the CIT phones. Please use email or chat if you are having problems getting connected to CIT on the phone.
Posted Oct 07, 2024 - 11:11 CDT
This incident affected: Managed Services (CIT Service Desk Phones).