Expired SSL Cert
Incident Report for CIT Services Status
Resolved
Control.cit-net.com has been updated and all services should be back to normal operation.
Posted Jun 20, 2023 - 10:30 CDT
Update
Proactvie.cit-net.com is back to normal operation with the renewed Cert installed.
Posted Jun 20, 2023 - 09:42 CDT
Identified
Support.cit-net.com is back up and secured with renewed SSL Certificate. Still working to apply renewed cert to Proactive and Control sites.
Posted Jun 20, 2023 - 09:37 CDT
Investigating
We are working to renew the SSL Certificate as quickly as possible.
Posted Jun 20, 2023 - 09:17 CDT
This incident affected: Managed Services (https://proactive.cit-net.com, https://control.cit-net.com, https://support.cit-net.com).